GoldenEye: Source Forums

  • November 19, 2019, 12:41:15 am
  • Welcome, Guest
Advanced search  

News:

Pages: 1 [2]  All   Go Down

Author Topic: Wine: Bad EXE  (Read 620 times)

0 Members and 1 Guest are viewing this topic.

ron

  • Agent
  • *
  • Posts: 8
  • Reputation Power: 1
  • ron has no influence.
  • Offline Offline
Re: Wine: Bad EXE
« Reply #15 on: October 23, 2019, 04:22:00 am »

EDIT 2: I've got things working!

In short, I stood up a dedicated server on Windows, had that working fine, and simply copied my entire server folder to my linux box in AWS, then ran the server there, this seems to have got things working... My server now correctly shows up in the server browser, and is a VAC secured server. Thank you so much to Soupcan and Kraid for taking the time out of their days to look into this for me.

The main take away is sometimes its quicker to just blow away what you have and start again (even doing this multiple times).  ;D


EDIT: Ignore this post, after I tried recreating what I was seeing in these screenshots with someone else, the results were inconsistent, but tended towards being able to connect to Valve servers and get VAC status. In addition the server was viewable in the server browser... Still have my problem with my AWS server, but am continuing with a few different experiments, one of which includes copying the server folder that I was running on my Windows desktop to my AWS Linux box and seeing if it runs without issue.


Odd...

I did spin up a server on my personal windows desktop just to see what happened.

Low and behold, it appears in the server browser... Until I close the steam application.

In any of the following scenarios, I see the following in the server console of my personal windows desktop

 - Steam desktop application is running, and logged in in online mode
 - Steam desktop application is running, and in offline mode
 - Steam desktop application is running, and I'm simply sat at the login screen

Server console in the above 3 scenarios:




If the Steam desktop application is closed down completely, I get the below in my server console, and presumably, cannot see the server in server browser.




Things like this make me feel as though something else is required here to get the srcds.exe communicating so that I get a VAC server which appears in server browser.


Cheers.

 -Ron
« Last Edit: October 23, 2019, 07:26:09 am by ron »
Logged

soupcan

  • Systems Administrator
  • 00 Agent
  • *
  • Posts: 260
  • Reputation Power: 178
  • soupcan is awe-inspiring!soupcan is awe-inspiring!soupcan is awe-inspiring!soupcan is awe-inspiring!soupcan is awe-inspiring!soupcan is awe-inspiring!soupcan is awe-inspiring!soupcan is awe-inspiring!soupcan is awe-inspiring!soupcan is awe-inspiring!soupcan is awe-inspiring!soupcan is awe-inspiring!
  • Offline Offline
    • Steam Profile
Re: Wine: Bad EXE
« Reply #16 on: October 24, 2019, 02:44:34 am »

Glad to hear you got it working! :)
Logged
Pages: 1 [2]  All   Go Up