GoldenEye: Source Forums

  • January 21, 2021, 08:17:58 am
  • Welcome, Guest
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: GAME MODE WON'T CYCLE FOR **** ON SERVER  (Read 4140 times)

0 Members and 1 Guest are viewing this topic.

click4dylan

  • Agent
  • *
  • Posts: 19
  • Reputation Power: 1
  • click4dylan has no influence.
  • Offline Offline
GAME MODE WON'T CYCLE FOR **** ON SERVER
« on: May 10, 2010, 02:07:05 pm »

ive waited all year long to host a server but it is IMPOSSIBLE because the game mode will NEVER cycle no matter WHAT you do. seriously, ****ing fix ge_gameplay_mode. neither value works at all. i'm trying to host a LTK and deathmatch server and it starts as deathmatch (regardless of ge_gameplay_mode), and then switches to LTK and never goes back to deathmatch. ive used 10 different server isntalls, two different machines and the hotfix, it DOES not change game modes. the server files are bugged beyond belief. is there ANY way to get this working? seriously this should have been fixed a long time ago (it's impossible to host a multiple game mode server). and no i dont have ge_gameplay set manually. ive tried putting ge_gameplay_mode in both server.cfg and autoexec.cfg (and removing from server.cfg) and setting it in command line. nothing works. gameplaycycle.txt has ltk and deathmatch on separate lines and ive tried adding them more than once.
Logged

major

  • On Vacation
  • Retired Developer
  • 007
  • ****
  • Posts: 1,841
  • Reputation Power: 110
  • major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!
  • Offline Offline
Re: GAME MODE WON'T CYCLE FOR **** ON SERVER
« Reply #1 on: May 10, 2010, 05:26:35 pm »

Try this:

in the valve.RC, make the ge_gameplay deathmatch or LTK
Code: [Select]
ge_gameplay deathmatch
in the server.cfg, set the ge_gameplay_mode to 2
Code: [Select]
ge_gameplay_mode 2

in the gameplaycycle.txt, have it just be LTK and Deathmatch.
Code: [Select]
DeathMatch
LTK

Try all that and if that doesn't work, we'll see if we can cook up a trick.
Logged
All view points are of my own and not associated with the team.

Rodney 1.666

  • Macc
  • 007
  • ****
  • Posts: 1,265
  • Reputation Power: 33
  • Rodney 1.666 is a rising star!Rodney 1.666 is a rising star!Rodney 1.666 is a rising star!Rodney 1.666 is a rising star!Rodney 1.666 is a rising star!Rodney 1.666 is a rising star!
  • Offline Offline
    • Steam profile
Re: GAME MODE WON'T CYCLE FOR **** ON SERVER
« Reply #2 on: May 10, 2010, 06:35:46 pm »

Capitalization plx.
Logged
Quote from: Friday, June 07, 2013
9:48 PM - Macc 1.666: So I post on GE:S after 6 months and Facility comes on Radio Nintendo
9:48 PM - Macc 1.666: think it's trying to tell me something
9:48 PM - Proxie: Tonight you will dream of Grant Kirkhope and VC

killermonkey

  • GES Programmer
  • Retired Lead Developer
  • GE:S Fanatic
  • *
  • Posts: 5,474
  • Reputation Power: 346
  • killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!
  • Offline Offline
    • DroidMonkey Apps
Re: GAME MODE WON'T CYCLE FOR **** ON SERVER
« Reply #3 on: May 11, 2010, 01:13:09 am »

YOU must be doing something wrong because the gameplay cycling works great after the hotfix is applied. autoexec.cfg does not get executed when the server runs unless you explicitly put that in valve.rc or server.cfg.

You should be putting one-off commands such as 'ge_gameplay_mode' in valve.rc which is executed only one when the server is started. server.cfg is executed on each map change. It is likely you still have the setting in valve.rc which may be overriding your choice (especially in autoexec.cfg since its not executed lol).

-- GRAMMAR NAZI --
You seem to have found your caps lock key for the thread title, but lost it again when you attempted to write the first letter of any sentence...
Logged

click4dylan

  • Agent
  • *
  • Posts: 19
  • Reputation Power: 1
  • click4dylan has no influence.
  • Offline Offline
Re: GAME MODE WON'T CYCLE FOR **** ON SERVER
« Reply #4 on: May 11, 2010, 07:46:00 am »

i never touched valve.rc. and i did +exec autoexec.cfg on the batch file, so it is loading autoexec.cfg. i tried putting ge_gameplay_mode 2 in the valve.rc anyway, still no luck. stuck on LTK forever after the first map change. seriously, even fresh install without changing a single thing it still does not cycle game modes    . at the moment i have nothing in autoexec, and my server.cfg contains:
Code: [Select]
sv_lan 0
sv_gravity 600
developer 3
phys_timescale 1.5
sv_alltalk 1
sv_maxunlag 0.5
fps_max 0
ge_roundtime 280
sv_region 3
hostname "~ Absolute DM/LTK ~ [1000FPS/100Tick]"
rcon_password "************"
mp_flashlight 1
mp_footsteps 1
mp_falldamage 1
mp_timelimit 12
mp_fraglimit 50
sv_turbophysics 0
mp_chattime 2
sv_maxrate 60000
sv_minrate 60000
sv_maxcmdrate 100
sv_maxupdaterate 100
sv_mincmdrate 100
sv_minupdaterate 100
sv_client_cmdrate_difference 17
sv_client_max_interp_ratio 3
sv_client_min_interp_ratio 2
log off
//sv_logbans 0
//sv_logecho 0
//sv_logfile 0
//sv_log_onefile 0
sv_allowdownload 1
sv_allowupload 1
decalfrequency 0.1
net_maxfilesize 64
sv_voiceenable 1
sv_cheats 0
sv_pausable 0
sv_client_predict -1

and my gameplaycycle.txt contains
Code: [Select]
LTK
Deathmatch


*edit
i finally got it to at least try to change game modes but it still isnt working properly, this is what its showing:

Code: [Select]
changelevel ge_complex
---- Host_Changelevel ----
Spawn Server: ge_complex: []
Loading: maps/ge_complex.bsp
exec: couldn't exec skill_manifest.cfg
Executing dedicated server config file
(1.01) input <NULL>: zz_ge_timelimit_timer.SetTime(12)
(1.01) input <NULL>: zz_ge_timelimit_timer.Enable(12)
Loading Gameplay LTK from disk

Gameplay MD5: d73da8b2b7cb94d1919f00c98d588982 (OFFICIAL)
Executing gamemode [LTK.cfg] config file
Loaded gamemode LTK
Set Gravity 600.0 (0.250 tolerance)
Created class baseline: 16 classes, 3606 bytes.
24 player server started
execing server.cfg
FCVAR_CHEAT cvars reverted to defaults.
execing LTK.cfg
Warning: Deleting orphaned children of func_rotating
ge_gameplay
"ge_gameplay" = "DeathMatch"
 game
 - Sets the current gameplay mode.
Default is 'deathmatch'.

so you see for the first time (not sure why) its actually trying to switch it, and it appears so, but when i type ge_gameplay it still shows deathmatch


**edit again, its not even attempting to change anymore. now its just loading deathmatch everytime and executing deathmatch.cfg
« Last Edit: May 11, 2010, 08:21:35 am by click4dylan »
Logged

major

  • On Vacation
  • Retired Developer
  • 007
  • ****
  • Posts: 1,841
  • Reputation Power: 110
  • major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!
  • Offline Offline
Re: GAME MODE WON'T CYCLE FOR **** ON SERVER
« Reply #5 on: May 11, 2010, 09:31:41 am »

when I get out of class tonight ill make a fresh new server and try it out. when ever I did gameplay cycle changes they worked, so I will see if it works.
Logged
All view points are of my own and not associated with the team.

click4dylan

  • Agent
  • *
  • Posts: 19
  • Reputation Power: 1
  • click4dylan has no influence.
  • Offline Offline
Re: GAME MODE WON'T CYCLE FOR **** ON SERVER
« Reply #6 on: May 14, 2010, 09:22:49 am »

wow still no reply? thats some support these forums have..
Logged

Enzo.Matrix

  • Lead Public Relations
  • GE:S Fanatic
  • *****
  • Posts: 3,094
  • Reputation Power: 158
  • Enzo.Matrix is awe-inspiring!Enzo.Matrix is awe-inspiring!Enzo.Matrix is awe-inspiring!Enzo.Matrix is awe-inspiring!Enzo.Matrix is awe-inspiring!Enzo.Matrix is awe-inspiring!Enzo.Matrix is awe-inspiring!Enzo.Matrix is awe-inspiring!Enzo.Matrix is awe-inspiring!Enzo.Matrix is awe-inspiring!Enzo.Matrix is awe-inspiring!Enzo.Matrix is awe-inspiring!
  • Offline Offline
Re: GAME MODE WON'T CYCLE FOR **** ON SERVER
« Reply #7 on: May 14, 2010, 09:40:13 am »

You can bitch about Dell support all you want.  Don't complain about something this is being provided completely free.
Logged
GoldenEye: Source Co-Creator
Personal Mission: -Play GE:S with a GE007 N64 Dev (Dr. Doak)
-GE:S reviewed by Yahtzee

CCsaint10

  • Nickname: "Saint"
  • 007
  • ****
  • Posts: 1,560
  • Reputation Power: 71
  • CCsaint10 is awe-inspiring!CCsaint10 is awe-inspiring!CCsaint10 is awe-inspiring!CCsaint10 is awe-inspiring!CCsaint10 is awe-inspiring!CCsaint10 is awe-inspiring!CCsaint10 is awe-inspiring!CCsaint10 is awe-inspiring!CCsaint10 is awe-inspiring!CCsaint10 is awe-inspiring!CCsaint10 is awe-inspiring!CCsaint10 is awe-inspiring!
  • Offline Offline
Re: GAME MODE WON'T CYCLE FOR **** ON SERVER
« Reply #8 on: May 14, 2010, 12:55:56 pm »

Major probably had something else that came up anyways, cut him a break. He is busy with classes and life...like everyone else on these forums.
Logged

Brings back memories, doesn't it? :D

major

  • On Vacation
  • Retired Developer
  • 007
  • ****
  • Posts: 1,841
  • Reputation Power: 110
  • major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!major is awe-inspiring!
  • Offline Offline
Re: GAME MODE WON'T CYCLE FOR **** ON SERVER
« Reply #9 on: May 14, 2010, 05:32:06 pm »

I tried it real quick, and it wasn't working, but busy with final papers. I'll try to work on it a little more this weekend.
Logged
All view points are of my own and not associated with the team.

killermonkey

  • GES Programmer
  • Retired Lead Developer
  • GE:S Fanatic
  • *
  • Posts: 5,474
  • Reputation Power: 346
  • killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!
  • Offline Offline
    • DroidMonkey Apps
Re: GAME MODE WON'T CYCLE FOR **** ON SERVER
« Reply #10 on: May 15, 2010, 02:12:39 am »

wow still no reply? thats some support these forums have..

First of all, dick move, no one cares if your server is inconvenienced unless you have sent me a $100 bill in the mail. Other than that, you have no grounds to complain AT ALL.

Secondly, I take responsibility for this bug. Apparently, ordered game mode doesn't cycle. Switch to random game mode to fix the bug (ge_gameplay_mode 1). It will never play the same line of the gameplaycycle.txt so if you only have two lines that means it will swap between the two.

Why you didn't try that to begin with, I'll never know, but this bug will be fixed in the next release.
Logged

click4dylan

  • Agent
  • *
  • Posts: 19
  • Reputation Power: 1
  • click4dylan has no influence.
  • Offline Offline
Re: GAME MODE WON'T CYCLE FOR **** ON SERVER
« Reply #11 on: May 16, 2010, 09:08:06 am »

i have tried 1 & 2, sorry for getting pissed just it could be stickied somewhere so people would know. thanks. and i uninstalled server btw because neither 1 or 2 would work still
Logged
Pages: [1]   Go Up