Editing and Customization > Resources, Tools, Tips & Workarounds

[FIX] ERROR: 'EXCEPTION_ACCESS_VIOLATION' (assert: 1) Maya Weight Painting


Konrad Beerbaum:
This fix specifically addresses the situation when this error is received for a file compiled during the weight painting process.  There are many other possible reasons for this error if it occurs in a situation without weight painting. This situation was with a file exported out of Maya as an SMD. 

Mishkin lower body weight painted, spine 85% done - Compiles fine.
Mishkin lower body weight painted, spine 100% done- Compiling Error.
Mishkin completely weight painted - Compiling Error.

------------------------Compiling Error----------------------------
Working on "Mishkin.qc"
SMD MODEL mishkin.smd
ERROR: Aborted Processing on 'players\mishkin\mishkin.mdl'

Nothing changed between the 85% and the 100% versions except for the weights.  The qc file and smd file are identical between the 2 versions except for the weights.

In this situation, the only fix that was found was to export the file out of Maya as an XSI file using the free crosswalk plugin from XSI.  The file was imported into XSI, and exported out of XSI as an SMD.  The SMD exported out of XSI avoided the compiling error. 

Do you know of any other solutions to this error message ?

I'm already using XSI and am pretty sure it is not a weight map issue. I started getting this error message after Source SDK updated itself on Nov. 7th.
I've been alerted to this possible solution:

"When running the Orange Box versions of the 'studiomdl' and 'vtex' you should include '-nop4' on the command line to bypass our Perforce integration with these tools. We will eliminate this need in a subsequent release."

I'm kind of confused as to where the "command line" is exactly. Does anyone know where I should put the "-nop4" text ?

Konrad Beerbaum:
When I did research before, it could be caused by a ton of different things.  None of them applied to me though, so I don't remember what they were.  Google the error code, thats how I found all my info about it. 

In XP, go to start, run, type cmd, and hit enter. The MS Dos window is called the command prompt.  There are two Valve suggested methods of compiling, doing it manually through the command prompt, and dragging and dropping onto the studiomdl.exe icon.  In order to add those commands, you need to use the command prompt method, because you have to enter a long string of commands, and you can add that -nop4 in there with them.  The command prompt is a pain in the ass, but it gives you the most flexibility. 

Thanks Konrad!

After more research I'm thinking that the "-nop4" thing is a dead end and doesn't really apply to my problem. I guess let me know if you hear of anything else relating to this damn error message.

Thanks again.

I know this is an old thread but I figured I'd share a find on this. When working on an update for the Wall Worm Model Tools (for 3ds Max) I ran into this. In my case, this same error was happening when I was setting a $masscenter position on a model using $collisionjoints. In my case, the fix was to not use $masscenter in $collisionjoints model.smd{}... only inside $collisionmodel.

Another thing I did while working on this was to make the collision mesh only list bones that control the collision hull... excluding those that are in the model but not the collision model.

Anyway, I hope this helps shed light on the whole thing.


[0] Message Index

Go to full version