GoldenEye: Source Forums

  • July 26, 2021, 03:06:40 am
  • Welcome, Guest
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: -debug mode  (Read 2703 times)

0 Members and 1 Guest are viewing this topic.

tsmith

  • Agent
  • *
  • Posts: 6
  • Reputation Power: 1
  • tsmith has no influence.
  • Offline Offline
-debug mode
« on: September 10, 2016, 05:53:13 am »

How do I enable it? The error message says to add it to my ./srcds_run command, but I've tried running it with the following and neither works:

MALLOC_CHECK_=0 ./srcds_run -debug -game /home/smitty/goldeneye/gesource/ +maxplayers 30 +map ge_dam

as well as

MALLOC_CHECK_=0 ./srcds_run -game /home/smitty/goldeneye/gesource/ +maxplayers 30 +map ge_dam -debug

And neither works. -- the terminal still says I should enable -debug to get the log file, and there is no debug.log in the folder I am running it in, my home folder, or in my gesource folder.

Running on ubuntu 14.04

*edit* I've also gone directly into srcds_run and modified the initial value of DEBUG from "" to 1, and it still seems to ignore it.

Thanks,

Smitty
« Last Edit: September 10, 2016, 06:32:01 am by tsmith »
Logged

killermonkey

  • GES Programmer
  • Retired Lead Developer
  • GE:S Fanatic
  • *
  • Posts: 5,472
  • Reputation Power: 345
  • killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!
  • Offline Offline
    • DroidMonkey Apps
Re: -debug mode
« Reply #1 on: September 10, 2016, 07:48:35 am »

need output of:    ldd server_i486.so

within the gesource/bin/ directory
Logged

tsmith

  • Agent
  • *
  • Posts: 6
  • Reputation Power: 1
  • tsmith has no influence.
  • Offline Offline
Re: -debug mode
« Reply #2 on: September 10, 2016, 08:40:26 am »

linux-gate.so.1 =>  (0xb771f000)
   libz.so.1 => /usr/lib32/libz.so.1 (0xb62d5000)
   libdl.so.2 => /lib32/libdl.so.2 (0xb62d0000)
   librt.so.1 => /lib32/librt.so.1 (0xb62c7000)
   libutil.so.1 => /lib32/libutil.so.1 (0xb62c3000)
   libnsl.so.1 => /lib32/libnsl.so.1 (0xb62aa000)
   steam_api_i486.so => not found
   tier0_i486.so => not found
   vstdlib_i486.so => not found
   libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xb61c1000)
   libm.so.6 => /lib32/libm.so.6 (0xb617b000)
   libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xb615e000)
   libc.so.6 => /lib32/libc.so.6 (0xb5fb2000)
   /lib/ld-linux.so.2 (0xb7720000)
   libpthread.so.0 => /lib32/libpthread.so.0 (0xb5f96000)


Thanks for the help!
« Last Edit: September 10, 2016, 08:42:47 am by tsmith »
Logged

cfultz

  • Agent
  • *
  • Posts: 1
  • Reputation Power: 0
  • cfultz has no influence.
  • Offline Offline
Re: -debug mode
« Reply #3 on: September 26, 2016, 05:02:06 pm »

Not attempting to hijack the thread but I'm having the same issue on Ubuntu. When I attempt to run the server, I receive the following (not sure if OP is experiencing this too or not):

Code: [Select]
Console initialized.
Segmentation fault
cat: hlds.2243.pid: No such file or directory
email debug.log to linux@valvesoftware.com
Mon Sep 26 23:56:37 EDT 2016: Server restart in 10 seconds
Mon Sep 26 23:56:40 EDT 2016: Server Quit

Everything else OP has above is identical to my installation (except my server is on 16.04). Tried it as well on 14.04 with the exact same problems. Both servers are 64-bit.

EDIT: Found this thread as well but the resolution of deleting and reinstalling the entire server doesn't seem to work for me (fourth reinstall).
« Last Edit: September 27, 2016, 05:20:06 am by cfultz »
Logged

killermonkey

  • GES Programmer
  • Retired Lead Developer
  • GE:S Fanatic
  • *
  • Posts: 5,472
  • Reputation Power: 345
  • killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!
  • Offline Offline
    • DroidMonkey Apps
Re: -debug mode
« Reply #4 on: September 27, 2016, 03:45:11 pm »

Not enough information to determine a cause
Logged
Pages: [1]   Go Up