GoldenEye: Source Forums

  • July 26, 2021, 03:38:03 am
  • Welcome, Guest
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Anayone know why GES became jittery and tearing after Win 10 upgrade?  (Read 1472 times)

0 Members and 1 Guest are viewing this topic.

Kiihhu

  • Agent
  • *
  • Posts: 28
  • Reputation Power: 2
  • Kiihhu has no influence.
  • Offline Offline

Hi, all! I have a performance issue that I don't believe is a bug in GES itself, but rather it's my computer that doesn't like GES anymore. I have uploaded a fraps sample video that demonstrates the problematic behavior here.

I am hoping to hear if anyone else has had this problem and if they have managed to fix it!


Things to note in the video:
  • Terrible tearing, especially when I turn around a corner! Very annoying, appeared after upgrading from Windows 7 to Windows 10 (a few months ago, so I had this problem also in GES 4.2.4. since this summer)!
  • The game is jittery.
  • No gun reload animation visible (see my DD44) when I reload, except when my clip runs dry and I am forced to reload. So strange...
  • Many visual effect are shown late. See how I shoot my Magnum and the muzzle flash shows up half a second late. There are other effects that behave like this too.
  • Perhaps not observable in this video, but I often hear a pistol fire sound in duplicate or triplicate. Firing a Silenced PP7 sounds like it fires a two-round burst and sometimes the Magnum sounds like it fires three-round bursts.



My FPS oscillates between 90-300 with all graphics settings at their maximum, mostly it is around 200 fps. I have tried turning on VSync, but that only makes the game super jittery! Setting graphics settings to their minimum does nothing to help the problem. I have previously tried to cap my FPS to lower values (200, 100, 60, 50 fps, again thank you Graslu for your help), but as far as I remember the tearing jittering only got worse when I lowered the max fps cap... Funny thing is, sometimes it's worse, and sometimes tolerable (sometimes the only symptom is tearing). It can be horrible even on a listen server I have created myself and where I have a ping of 5.

I have a 10 years old 60 Hz analog screen that has no drivers for Windows 7 or Windows 10, but it worked fine until I upgraded to Windows 10. Maybe the missing driver is the real issue here? On the other hand, games like Half Life 2, CS:GO, and Outlast work perfectly!

My system specs are:
  • GPU: NVIDIA GeForce GTX 750 Ti  (2048 MB)
  • Graphics Driver: GeForce Game Ready Driver v. 368.81 (14.7.2016)
  • Screen: Acer X223W (60 Hz, 22" LCD, analog, 16:10, 1680 x 1050 native resolution)
  • Processor: QuadCore AMD Phenom II X4 Black Edition 965, 3375 MHz (17 x 199)
  • RAM: 8192 MB  (DDR3 SDRAM)
  • Operating System: Windows 10, 64 bit
  • DirectX: DirectX 12.0

« Last Edit: August 14, 2016, 02:24:46 am by Kiihhu »
Logged

Graslu

  • You can't win.
  • Tester
  • Secret Agent
  • **
  • Posts: 196
  • Reputation Power: 143
  • Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!
  • Offline Offline
    • YouTube
Re: Anayone know why GES became jittery and tearing after Win 10 upgrade?
« Reply #1 on: August 14, 2016, 04:43:40 am »

This reminds me to the issue I had on a in-development update of 5.0. The game felt laggy as if it was actual high ping, no animations on guns, etc.
It was caused by a corrupt .cfg file. The problem is that I don't remember which one caused it, but I'm pretty sure it was one of these:

Go into gesource/cfg and look for listenserver.cfg, move that file outside of the folder and try again.
If it's still happening, move all the server_X.cfg files out too and try again.

That should fix it, if it keeps happening, I'll send you my cfg folder to you through Steam and I'm pretty sure it should be fixed after that.

Kiihhu

  • Agent
  • *
  • Posts: 28
  • Reputation Power: 2
  • Kiihhu has no influence.
  • Offline Offline
Re: Anayone know why GES became jittery and tearing after Win 10 upgrade?
« Reply #2 on: August 14, 2016, 07:24:52 am »

Thanks again for your help, Graslu.

I did what you suggested, moved all the server___.cfg files somewhere else and then I gave it a try. First everything looked alright, until I ended up to Stack_classic map, where usually the tearing is at its worst. Now my Magnum truly shoots twice. I don't know if both shots are lethal, or only the first, but it looked like I could literally shoot 12 round by shooting 6 times (new demo video here).

This is the main reason I haven't been playing GES for some months and I truly want to get it fixed. Who knows what else is going on in the game that isn't supposed to happen but I just don't know about. I really hope someone knows how to fix this.  :-\

Logged

Graslu

  • You can't win.
  • Tester
  • Secret Agent
  • **
  • Posts: 196
  • Reputation Power: 143
  • Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!Graslu is awe-inspiring!
  • Offline Offline
    • YouTube
Re: Anayone know why GES became jittery and tearing after Win 10 upgrade?
« Reply #3 on: August 14, 2016, 08:13:47 am »

Alright, I'll send you my cfg folder. You'll get my settings and bindings (Just f9 for console and f10 for sm_admin), change those to fit yours and you should be good to go.
Pages: [1]   Go Up