GoldenEye: Source Forums

  • July 27, 2021, 05:41:10 pm
  • Welcome, Guest
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Help with Occasional Sound/Video Freeze  (Read 1155 times)

0 Members and 1 Guest are viewing this topic.

007rocks

  • Agent
  • *
  • Posts: 4
  • Reputation Power: 0
  • 007rocks has no influence.
  • Offline Offline
Help with Occasional Sound/Video Freeze
« on: February 04, 2012, 03:33:37 pm »

Hello,

I have been running into a weird issue randomly when playing GE:S.

Randomly, a sound clip will start repeating, the video will go extremely slow like maybe a frame every 2-3 seconds and then I finally regain control and everything works like normal.

Any ideas what could be causing this?

Thanks!
Logged

Emilia

  • 00 Agent
  • ***
  • Posts: 446
  • Reputation Power: 87
  • Emilia is awe-inspiring!Emilia is awe-inspiring!Emilia is awe-inspiring!Emilia is awe-inspiring!Emilia is awe-inspiring!Emilia is awe-inspiring!Emilia is awe-inspiring!Emilia is awe-inspiring!Emilia is awe-inspiring!Emilia is awe-inspiring!Emilia is awe-inspiring!Emilia is awe-inspiring!
  • Offline Offline
Re: Help with Occasional Sound/Video Freeze
« Reply #1 on: February 04, 2012, 04:19:27 pm »

It sounds like computer lag. I get this too. I play on a laptop that is starting to get old and outdated.

It sucks, because now I have to play on the lowest settings.

What kind of computer do you have?
Logged
MaJoR: "This is sooooooooooooooooooooooooooooo getting to be awesome"

Jonathon [SSL]

  • Generalist
  • Retired Lead Developer
  • 007
  • *
  • Posts: 1,311
  • Reputation Power: 99
  • Jonathon [SSL] is awe-inspiring!Jonathon [SSL] is awe-inspiring!Jonathon [SSL] is awe-inspiring!Jonathon [SSL] is awe-inspiring!Jonathon [SSL] is awe-inspiring!Jonathon [SSL] is awe-inspiring!Jonathon [SSL] is awe-inspiring!Jonathon [SSL] is awe-inspiring!Jonathon [SSL] is awe-inspiring!Jonathon [SSL] is awe-inspiring!Jonathon [SSL] is awe-inspiring!Jonathon [SSL] is awe-inspiring!
  • Offline Offline
    • Steam Community Page
Re: Help with Occasional Sound/Video Freeze
« Reply #2 on: February 04, 2012, 05:58:01 pm »

It's related to your computer not loading the sounds fast enough for the Source Engine.


Source, in order to save memory, only loads the first 125 ms of each sound that's defined in the sound cache files. So, every time you play a new sound that hasn't been played before and therefore not fully loaded into memory, the engine has to wait for the hard drive to send it the sound data. If it doesn't get the full data before the cached 125 ms are played, it re-loops back to the beginning of the 125 ms until the full sound gets loaded and played.


Even on my quad-core computer with 6 GB of RAM I get this issue occasionally, and it happens more frequently the older your computer or slower you hard drive (happened a lot more on my old computer).


More technical info:
https://developer.valvesoftware.com/wiki/Soundcache
Logged
Quote
Luchador: I NEVER NAME MY FILES IN UPPER CASE
Luchador: I ONLY TALK IN UPPER CASE
[GE:S] killermonkey: GOOD TO KNOW

Mangley

  • Leads The Art
  • Lead Artist
  • 007
  • *****
  • Posts: 1,848
  • Reputation Power: 270
  • Mangley is awe-inspiring!Mangley is awe-inspiring!Mangley is awe-inspiring!Mangley is awe-inspiring!Mangley is awe-inspiring!Mangley is awe-inspiring!Mangley is awe-inspiring!Mangley is awe-inspiring!Mangley is awe-inspiring!Mangley is awe-inspiring!Mangley is awe-inspiring!Mangley is awe-inspiring!
  • Offline Offline
Re: Help with Occasional Sound/Video Freeze
« Reply #3 on: February 05, 2012, 04:40:29 am »

Make sure you have hardware acceleration turned on in your Windows sound options.
Logged
Concept Artist, Environment Artist, Effects Artist, Sound Designer

007rocks

  • Agent
  • *
  • Posts: 4
  • Reputation Power: 0
  • 007rocks has no influence.
  • Offline Offline
Re: Help with Occasional Sound/Video Freeze
« Reply #4 on: February 05, 2012, 04:56:45 pm »

Thanks for the speedy responses!

I have a new system with an i7, sli 460s, and no sound card (mobo sound). I have never encountered this sound issue before in other games.

My hard drive is an eco barracuda green hard drive so it is definitely not very fast. It could probably be causing the issue of not loading sounds fast enough.

Is there perhaps a setting in valve to up the cache size? Or some other way to mitigate the issue?

Thanks! :)
Logged
Pages: [1]   Go Up