GoldenEye: Source Forums

  • July 27, 2021, 06:25:27 pm
  • Welcome, Guest
Advanced search  


Pages: [1]   Go Down

Author Topic: Segmentation Fault (core dumped) on Ubuntu 18.04 x64  (Read 3126 times)

0 Members and 1 Guest are viewing this topic.


  • Agent
  • *
  • Posts: 1
  • Reputation Power: 0
  • Daereius has no influence.
  • Offline Offline
Segmentation Fault (core dumped) on Ubuntu 18.04 x64
« on: May 21, 2018, 01:32:39 pm »

Hello all... I'm trying to set up a GE:S on Ubuntu 18.04, but I'm running into the Segmentation fault (core dumped) error. I followed the SteamCMD guide and the GES guide on the wiki, and I spent quite a few hours trying to troubleshoot, and followed along with the thread regarding the same problem using Ubuntu 16.04. Even though the issues may be so similar, I'd rather make a new thread than piggyback off a dead one.

I'm trying to run this script 'sudo ./'
MALLOC_CHECK_=0 /home/steam/srcds_run -debug -console -game /home/steam/gesource/ +maxplayers 16 +map ge_archives

Console initialized.
Segmentation fault (core dumped)
cat: No such file or directory
email debug.log to
Mon May 21 19:46:56 EDT 2018: Server restart in 10 seconds
Mon May 21 19:46:58 EDT 2018: Server Quit

dump of sudo ldd ./gesource/BIN/
Quote (0xf7f58000) => /lib/i386-linux-gnu/ (0xf6af1000) => /lib/i386-linux-gnu/ (0xf6aec000) => /usr/lib/i386-linux-gnu/ (0xf6a90000) => /lib/i386-linux-gnu/ (0xf6a86000) => /lib/i386-linux-gnu/ (0xf6a82000) => /lib/i386-linux-gnu/ (0xf6a67000) => not found => not found => not found => /usr/lib32/ (0xf68e1000) => /lib/i386-linux-gnu/ (0xf67dd000) => /lib/i386-linux-gnu/ (0xf67bf000) => /lib/i386-linux-gnu/ (0xf65e3000)
   /lib/ (0xf7f5a000) => /usr/lib/i386-linux-gnu/ (0xf65d3000) => /lib/i386-linux-gnu/ (0xf65bb000) => /usr/lib/i386-linux-gnu/ (0xf659d000) => /usr/lib/i386-linux-gnu/ (0xf6556000) => /usr/lib/i386-linux-gnu/ (0xf63c0000) => /lib/i386-linux-gnu/ (0xf63a1000) => /usr/lib/i386-linux-gnu/ (0xf6397000) => /usr/lib/i386-linux-gnu/ (0xf62f8000) => /usr/lib/i386-linux-gnu/ (0xf6245000) => /lib/i386-linux-gnu/ (0xf6240000) => /usr/lib/i386-linux-gnu/ (0xf6204000) => /usr/lib/i386-linux-gnu/ (0xf61ec000) => /usr/lib/i386-linux-gnu/ (0xf609e000) => /usr/lib/i386-linux-gnu/ (0xf6080000) => /usr/lib/i386-linux-gnu/ (0xf5eff000) => /usr/lib/i386-linux-gnu/ (0xf5eea000) => /usr/lib/i386-linux-gnu/ (0xf5eae000) => /usr/lib/i386-linux-gnu/ (0xf5e78000) => /usr/lib/i386-linux-gnu/ (0xf5deb000) => /usr/lib/i386-linux-gnu/ (0xf5dc1000) => /usr/lib/i386-linux-gnu/ (0xf5db0000) => /usr/lib/i386-linux-gnu/ (0xf5d61000) => /usr/lib/i386-linux-gnu/ (0xf5c43000) => /lib/i386-linux-gnu/ (0xf5c11000) => /usr/lib/i386-linux-gnu/ (0xf5c08000)

I was also running into a different issue with missing assets, but was able to correct it by using a script found in another thread to capitalize the folders in the gesource directories.
for i in `find . -type d`; do new_name=`echo $i | tr '[a-z]' '[A-Z]'`; mv $i $new_name ; done

I set a rule for port 27015 on ufw, and also tried it with ufw disabled.  I also have port forwarding set up. I don't feel that either of these things are causing my issues though... I've outlined pretty much everything I've tried so far, but does anyone else have any suggestions?
« Last Edit: May 22, 2018, 01:10:41 pm by Daereius »
Pages: [1]   Go Up