GoldenEye: Source Forums

  • September 28, 2021, 03:29:04 pm
  • Welcome, Guest
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: LAN Server Discovery Issues With LAN IP Set As Variable  (Read 3265 times)

0 Members and 1 Guest are viewing this topic.

iMouse

  • Agent
  • *
  • Posts: 9
  • Reputation Power: 1
  • iMouse has no influence.
  • Offline Offline
LAN Server Discovery Issues With LAN IP Set As Variable
« on: January 21, 2015, 04:29:47 pm »

I feel like the answer to this is going to be a *facepalm* moment for me, but here goes...

So I realized today that I was unable to use rcon to make in-game modifications to settings.  Sending any commands after rcon_password mypasswordgoeshere would result in a response that the server was not found at 192.168.0.100:27015 (the LAN IP of the server and port number).  I read some HL2 forums stating that for some odd reason on Linux, you have to specify +ip 192.168.0.100 in your command line or script.

Sooo, I did exactly that...rcon works now, but the server no longer appears automatically in the LAN tab in the GE:S client.  I have to manually specify an IP or hostname to connect to the server.  If I remove +ip 192.168.0.100, I get the server back in the LAN tab, but no rcon access.  Flagging rcon_address seems to do nothing.

I have double-checked that all clients are on the same subnet, same VLAN, even the ports on the switch are all set to access.  I have no internal firewall or rules blocking traffic internally between clients.

Ideas?

No LAN Autodiscovery, have rcon access
Code: [Select]
#!/bin/sh
export MALLOC_CHECK_=0
cd /home/steam/steamcmd/srcds/
./srcds_run -game ../gesource \
  +ip 192.168.0.100 \
  -port 27015 \
  +maxplayers 16 \
  +map ge_archives \
  -debug > /dev/null &

LAN Autodiscovery, no rcon access
Code: [Select]
#!/bin/sh
export MALLOC_CHECK_=0
cd /home/steam/steamcmd/srcds/
./srcds_run -game ../gesource \
  -port 27015 \
  +maxplayers 16 \
  +map ge_archives \
  -debug > /dev/null &
Logged

killermonkey

  • GES Programmer
  • Retired Lead Developer
  • GE:S Fanatic
  • *
  • Posts: 5,472
  • Reputation Power: 345
  • killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!
  • Offline Offline
    • DroidMonkey Apps
Re: LAN Server Discovery Issues With LAN IP Set As Variable
« Reply #1 on: January 23, 2015, 03:40:23 pm »

Rcon is transmitted over tcp port 27015 it might be because the firewall in Linux is blocking the tcp requests when you don't specify the ip address.
Logged

iMouse

  • Agent
  • *
  • Posts: 9
  • Reputation Power: 1
  • iMouse has no influence.
  • Offline Offline
Re: LAN Server Discovery Issues With LAN IP Set As Variable
« Reply #2 on: January 25, 2015, 06:10:14 am »

Rcon is transmitted over tcp port 27015 it might be because the firewall in Linux is blocking the tcp requests when you don't specify the ip address.

I would think that if 27015 was blocked at the server, the game wouldn't be playable at all either.  I'll double-check, but I'm pretty sure I didn't add the ipfw service when I installed Ubuntu Server.  The server is live on the net if I enable 27015 through the border firewall as well...just no rcon.
Logged
Pages: [1]   Go Up