GoldenEye: Source Forums

  • September 17, 2021, 02:54:09 am
  • Welcome, Guest
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Help with Dedicated server issues  (Read 3910 times)

0 Members and 1 Guest are viewing this topic.

Severs

  • Agent
  • *
  • Posts: 10
  • Reputation Power: 1
  • Severs has no influence.
  • Offline Offline
Help with Dedicated server issues
« on: May 05, 2013, 03:44:06 pm »

Ok, so I have fumbled (first time setting up a dedicated server for anything) around and been able to make a server for GES, had a bunch of issues, now am down to a few and am unsure of how to proceed. These are issues I have tried to search for and had no real answer that I could see.

Issue number 1. I attempted to put in UMC, it will not load due to an error: [SM] Unable to load plugin "umc-core.smx": Native "GetURandomFloat" was not found.

Issue number 2. This I am assuming is due to the above error causing the proper mapvote not to appear, but I am listing it anyway. After a few matches the mapvote system that is in place loses the amount of maps that is in it. Example, first 2 or 3 matches there is a constant 6 maps in the list. After the 4th match mapvote comes up there is 3, that last for a few matches, then it goes down to 2 maps in the list. After it hits 2 it will fluctuate at random in between 1 and 3 maps in the list.

Issue number 3. After leaving the server up for extended periods of time I am finding it where I cannot see my server in my favorites or lan tabs of the server browser. I have to connect manually using the connect (IP) command in console. Originally I had figured this no big deal, until I asked a friend to attempt to look for it and connect. While he could see it, it told him that there were 11 out of 10 players in the server, and would not allow him to connect. On one hand I could decide to just bring up my server when I wish to play, but I would rather leave it up as much as possible (unless my bandwidth is needed elsewhere) so others can join and perhaps fav it and come back regularly.

Any help regarding these issues I am having would be greatly appreciated. Thank you in advance.
Logged

killermonkey

  • GES Programmer
  • Retired Lead Developer
  • GE:S Fanatic
  • *
  • Posts: 5,472
  • Reputation Power: 345
  • killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!killermonkey is awe-inspiring!
  • Offline Offline
    • DroidMonkey Apps
Re: Help with Dedicated server issues
« Reply #1 on: May 05, 2013, 03:49:07 pm »

for #3, I am assuming you are running bots in the server. When you do this they will never be kicked from the server even after a map change and all human players have left. This is a Valve bug that they refuse to fix and we cannot do anything about it.

Suggest you DO NOT run bots on your server unless you restart it afterwards.
Logged

Severs

  • Agent
  • *
  • Posts: 10
  • Reputation Power: 1
  • Severs has no influence.
  • Offline Offline
Re: Help with Dedicated server issues
« Reply #2 on: May 05, 2013, 03:53:53 pm »

Thank you for the fast reply, yes, I did have it set up to run 1 bot if no one else was in the server, I will change that to no bots and see what it does over the next day or so.
Logged
Pages: [1]   Go Up